I'm Casting Magic Missle!

Blizzard’s Heroes of the Storm On Linux Via Wine

These instructions should allow you to install Blizzard Updater and Heroes of the Storm on Linux using Wine. From what I understand these instructions will allow some of the other Blizzard games to be run on Linux as well.
HOTS

First install wine 1.7.

In a terminal type:

sudo add-apt-repository ppa:ubuntu-wine/ppa
Hit Enter

and then:

sudo apt-get update; sudo apt-get install wine1.7 winetricks
Hit Enter

and then:

winetricks wininet allfonts
Hit Enter

Allfonts installs several windows fonts. It may not be absolutely necessary but it’s quick and easy to install and you really can’t go wrong doing it.

Finally run winecfg from the terminal or find “Configure Wine” in your desktop menu. Go to the “libraries” tab. You should see wininet(native,builtin) already listed there. Leave it be.

In the field labeled “New override for library” type in:
dbghelp
click add
click Yes on the dialogue that pops up.

In the field labeled “New override for library” type in:
msvcp100
click add
click ok

Download and install the client from http://us.battle.net/heroes/en/

If you launch the game and receive a crash error report dialogue you may need to switch the game to 32bit mode. Do the following from the Battle.net launcher:

Click the Battle.net logo(upper left)
Select “Settings”
Select “Game Settings”
In the Heroes of the Storm section check “Launch 32bit Client (instead of 64bit)”

Enjoy playing Heroes of the Storm on Linux!

Advertisements

Comments are closed.